iTrack Dock by Focusrite

iTrack Dock by Focusrite

I’ve been using the Focusrite iTrack Dock ($199) since Nov 9 of last year and I was excited about getting it for two reasons:
1. It appeared to be the most professional way to interface my iPad for recording music.
2. Focusrite is a highly respected company for audio gear.

All was great for the first few times I used the dock with my iPad 4 running iOS7.1.2. I was needing several inputs for the special way I have been wanting to use the iPad as an effects unit for my Electric Trombone and also be able to plug and play my MIDI keyboard at the same time. (most simple I/O only allow 1 in and 1 out) I already have a sophisticated electric trombone setup using my laptop, Ableton Live and MIDI foot pedals but I’ve been wanting to create a smaller simpler rig for random gigs and sitting in with other artists (2 min setup vs. 30 min).

Electric Trombone DJ - Darren Kramer
Here’s the apps I have been using:

1. JamUp Pro XT – for effects on my trombone sound
2. GarageBand – for good organ and rhodes keyboard sounds
3. Burn – for a very funky play along of live instruments
4. AudioBus – utility for running several audio apps simultaneously on an iPad

 

product-img-what-is-itrack

 

Problem is that aside from my few initial fun and successful sessions using the iTrack Dock, it has continually let me down in both practice and performance situations. I’m not sure of the exact culprit or combination of apps but just last week during an educational clinic in Aspen, the audio from the iPad cutout 5x during a performance. Moreover, the iTrack often disconnects from the iPad audio, resulting in that oh-so-enjoyable high squeal feedback. Luckily, the iPad is already disconnected from the dock – and speakers and/or headphones – before it feeds back which has fortunately saved my hearing. Nonetheless, I have experimented with many different apps and scenarios to hopefully discover the unique destructive problem but to no avail. It just seems to be the unit itself, and that is what the support team at Focusrite has concluded.

Yes, that is the bright side of the story – Focusrite support has been responsive, but not especially speedy. I sent my first inquiry to them on Feb 16. Today it’s March 9 and I’m still waiting for RA number to return it to be serviced (since my 30 days have passed since purchasing from Guitar Center). Focusrite has troubleshooted many aspects of this piece of gear and has assured me that iOS7, an iPad 4, and AudioBus are not the issue. Therefore, I am hopefully sending it to them for repair this week (shipping at my cost one way). However, now that I have another educational clinic at Colo State University on Thurs I’ve had to find a midterm solution for using my iPad as an effects unit for my trombone. So, I’m looking forward to receiving an Apogee Jam 96K Lightning Guitar Input ($129) in the mail tomorrow. Please know that I’ll do a follow up blog about this issue once a solution is discovered. Wish me luck!

jam-96k-perspective-hero-710

, , , , , , , , , ,

4 Responses to iTrack Dock by Focusrite

  1. Elisa Gonzalez 9 March 2015 at 8:01 pm #

    Good luck, Darren! I will be very interested in learning how this scenario plays out. Wishing you good luck this week, too, in the interim.

  2. Henrik 28 August 2015 at 4:40 am #

    Hi Darren
    I’ve got about 20 iTrack Dock’s with different ipads and recording software in the field. The failure you explained happens now and then for me too. Suddenly the Dock looses the connection to the ipad, with the error in upper right corner: no charging.
    A restart of the itrack is nessesary. Please let me hear about your results.

    • Darren Kramer 28 August 2015 at 1:35 pm #

      Hi Henrik! Thanks for your email but unfortunately I have only a short answer for you. I ended up sending in for repair at Focusrite (my only cost was shipping) and it came back working. I was happy of course but I was a big disappointed that even the packing slip had no indication whatsoever about what had actually been resolved, even despite my emailing them to inquire. Nevertheless, it’s been working fine with iPad 4 using iOS7 and JamUp Pro XT app. I would contact Focusrite about a solution, especially since you have twenty of them!!! Good luck.

  3. Pat Love 8 October 2015 at 10:12 am #

    I’m having the same issue. I had to go back to my alesis with an adaptor. Thanks for posting.

Leave a Reply